Air Bag Light On ?

The stock systems

Moderator: F9K9

Air Bag Light On ?

Postby killian96ss » Mon Mar 15, 2004 10:27 am

Has anyone ever had the Air Bag Readiness Light stay on after off roading? I was wheeling yesterday through some canyons when I happened to notice that my air bag light was stuck on! I immediately pulled the SIR fuse to prevent the bags from deploying for whatever reason. The FSM says that if the light stays on that there is some sort of failure in the system and that the air bags may not work in an accident or they may go off without warning ( not good ). I will be taking the truck in very soon, but I was just curious if anyone else has had this problem. Thanks, Steve.
2005 ZR2 Blazer / Mods- Spectre CAI, Descreened MAF, Shaved Throttle Blade, 31" Goodyear Kevlar MT/R's, Black Rock Rims, MSD Street Fire CDI & Super Conductor Wires, Accel Cap, Rotor & Coil, Flowmaster 30 Series, Gibson Tailpipe, ES Bushings, Goodridge Brake Lines, Power Slot Rotors - 1996 Impala SS / Mods- Too Many To List - 1988 S10 Blazer / Mods- Too Many To List - 2001 S10 Crew Cab 4x4 / Mods- Too Many To List *Wrecked 12/06*
User avatar
killian96ss
Crew K Elite
Crew K Elite
 
Posts: 2666
Joined: Tue Sep 09, 2003 11:53 am
Location: Rocklin, California

Re: Air Bag Light On ?

Postby kf6kmx » Fri Oct 15, 2004 3:20 pm

killian96ss wrote:Has anyone ever had the Air Bag Readiness Light stay on after off roading? I was wheeling yesterday through some canyons when I happened to notice that my air bag light was stuck on! I immediately pulled the SIR fuse to prevent the bags from deploying for whatever reason. The FSM says that if the light stays on that there is some sort of failure in the system and that the air bags may not work in an accident or they may go off without warning ( not good ). I will be taking the truck in very soon, but I was just curious if anyone else has had this problem. Thanks, Steve.


Yep.. Had it in my '03... no idea why though since the dealer was stupid and didnt check it when I took it in...
It came on leaving work here at the air base, I took it straight to a dealer (if the bag light goes off, there is no stored codes and they cant diagnose it.. it only gives a code when the light is actually on.. a friend had this problem in an Avalanche).. They said "we're too busy to look at it (I left it running in the parking lot to keep the light on) and to bring it back in 2 days.." I told them it will clear the codes. his response was "no it wont, it'll still be there"... Fine I took it back in 2 days (of course the light cycled out as soon as I turned off the engine), his reponse after keeping the truck for an hour, loosing my radio memories from having the battery unhooked, was "it cant be found unless the light is on at the time".. I told him "thats what I told you when i brought it in the first time" :poke: .. no reponse at all.. unfortunetly, if it does it again, my warranty has run out from mileage (19months old and I have 37k on it!)..
Also, when they put the battery neg cable back on, they didnt tighten it all the way, causing it to work loose over the next 2 weeks, but thats a completely different story..
-Scott-----'03 CrewCab S10 - Pewter
http://www.kf6kmx.net/s10tracker.asp<-- Follow this link to find my trucks current actual location! Updated whenever the ignition is on. (tracker radio is currently intermittant) Pioneer XM, MagnaFlow, Garmin GPS,Tornado AMS , APRS Tracker, 2m/440 Ham Radio, Vista Camper Shell (from SoCalDave) , JottoDesk laptop mount, Rancho 5000's, Revo 235 75R15 on stock rims
User avatar
kf6kmx
Crew Elite
Crew Elite
 
Posts: 272
Joined: Tue Oct 12, 2004 3:31 pm
Location: Hanford, CA

Postby killian96ss » Sat Oct 16, 2004 7:46 am

I had about the same experience at the dealer. When I went to have it checked out, they told me that I would need an appointment, and that they could see me the next day. Well guess what, the next morning when I started my truck no air bag light, and when they checked it out they told me that there were no codes stored and they could'nt find anything wrong. :!: The light has never come back on, but I would still like to know what happened.

Steve
2005 ZR2 Blazer / Mods- Spectre CAI, Descreened MAF, Shaved Throttle Blade, 31" Goodyear Kevlar MT/R's, Black Rock Rims, MSD Street Fire CDI & Super Conductor Wires, Accel Cap, Rotor & Coil, Flowmaster 30 Series, Gibson Tailpipe, ES Bushings, Goodridge Brake Lines, Power Slot Rotors - 1996 Impala SS / Mods- Too Many To List - 1988 S10 Blazer / Mods- Too Many To List - 2001 S10 Crew Cab 4x4 / Mods- Too Many To List *Wrecked 12/06*
User avatar
killian96ss
Crew K Elite
Crew K Elite
 
Posts: 2666
Joined: Tue Sep 09, 2003 11:53 am
Location: Rocklin, California

Postby kf6kmx » Sat Oct 16, 2004 8:08 am

killian96ss wrote:I had about the same experience at the dealer. When I went to have it checked out, they told me that I would need an appointment, and that they could see me the next day. Well guess what, the next morning when I started my truck no air bag light, and when they checked it out they told me that there were no codes stored and they could'nt find anything wrong. :!: The light has never come back on, but I would still like to know what happened.

Steve


Yep.. same exact thing..

My dad has an '03 Ex-Cab 2wd S10.. he said his airbag light came on once for a few hours also.. Almost wonder if it is something in the airbag control on these trucks.. almost like the old 'Service Engine' flag that would creep up out of the odometer on the early 80's GM trucks.. :?
-Scott-----'03 CrewCab S10 - Pewter
http://www.kf6kmx.net/s10tracker.asp<-- Follow this link to find my trucks current actual location! Updated whenever the ignition is on. (tracker radio is currently intermittant) Pioneer XM, MagnaFlow, Garmin GPS,Tornado AMS , APRS Tracker, 2m/440 Ham Radio, Vista Camper Shell (from SoCalDave) , JottoDesk laptop mount, Rancho 5000's, Revo 235 75R15 on stock rims
User avatar
kf6kmx
Crew Elite
Crew Elite
 
Posts: 272
Joined: Tue Oct 12, 2004 3:31 pm
Location: Hanford, CA

Postby killian96ss » Wed Mar 16, 2005 1:34 pm

Well, the Air Bag light is back on again. :? Once again after off roading and driving across a few water crossings it came back on. It has been on now for 2 weeks and I am getting a P0126 code. I cleared the code with the HPPIII, but the light is now stuck on. I've tried pulling the fuse and disconnecting the battery, but it won't go away! :roll: I can't seem to find an explanation for the P0126 anywhere. :x I know someone is going to say take it to the dealer, but I have to pay a $100 deductable for my extended warranty. I would like to fix this on my own if possible. When the light came on before it only lasted 2-3 days before turning itself off. Any ideas?

Steve
2005 ZR2 Blazer / Mods- Spectre CAI, Descreened MAF, Shaved Throttle Blade, 31" Goodyear Kevlar MT/R's, Black Rock Rims, MSD Street Fire CDI & Super Conductor Wires, Accel Cap, Rotor & Coil, Flowmaster 30 Series, Gibson Tailpipe, ES Bushings, Goodridge Brake Lines, Power Slot Rotors - 1996 Impala SS / Mods- Too Many To List - 1988 S10 Blazer / Mods- Too Many To List - 2001 S10 Crew Cab 4x4 / Mods- Too Many To List *Wrecked 12/06*
User avatar
killian96ss
Crew K Elite
Crew K Elite
 
Posts: 2666
Joined: Tue Sep 09, 2003 11:53 am
Location: Rocklin, California

Postby HenryJ » Wed Mar 16, 2005 6:15 pm

SIR trouble codes should be "B" codes

Are you sure it is not DTC B0026?

None of the SIR codes are triple digit all B00XX , except for B1001

"Speed doesn't kill, suddenly becoming stationary does." - Richard Hammond
"Speed is just a matter of Money - How fast do YOU want to go?"-Mechanic from Mad Max-
If at first you don't succeed - Don't take up Skydiving!
- ThunderII KE7CSK
User avatar
HenryJ
Admin K Elite
Admin K Elite
 
Posts: 12693
Joined: Tue Oct 01, 2002 9:14 pm
Location: Ontario, Oregon

Postby killian96ss » Wed Mar 16, 2005 6:28 pm

HenryJ wrote:SIR trouble codes should be "B" codes

Are you sure it is not DTC B0026?

None of the SIR codes are triple digit all B00XX , except for B1001
My Hypertech definitely read P0126. Maybe it's not designed to pick up B codes? :?

Steve
2005 ZR2 Blazer / Mods- Spectre CAI, Descreened MAF, Shaved Throttle Blade, 31" Goodyear Kevlar MT/R's, Black Rock Rims, MSD Street Fire CDI & Super Conductor Wires, Accel Cap, Rotor & Coil, Flowmaster 30 Series, Gibson Tailpipe, ES Bushings, Goodridge Brake Lines, Power Slot Rotors - 1996 Impala SS / Mods- Too Many To List - 1988 S10 Blazer / Mods- Too Many To List - 2001 S10 Crew Cab 4x4 / Mods- Too Many To List *Wrecked 12/06*
User avatar
killian96ss
Crew K Elite
Crew K Elite
 
Posts: 2666
Joined: Tue Sep 09, 2003 11:53 am
Location: Rocklin, California

Postby Retep » Thu Mar 17, 2005 6:07 am

killian96ss wrote:... I know someone is going to say take it to the dealer, but I have to pay a $100 deductable for my extended warranty.


OK I won't say "take it to the dealer" :wink:
2002 S10 Ext. Cab 4x4 Indigo Blue
Extang Black Max Tonneau, Rubber Bed Mat, Vent Visors, Bugflector II, SilverStar headlights, Dark Window Tint, Disabled DRL, Debadged, K&N Filter, Skid Plates, 1.25" Rear Wheel Spacers, Boise 3 aal kit, mild T-bar crank, Dueler A/T Revo
User avatar
Retep
Crew Elite
Crew Elite
 
Posts: 313
Joined: Mon Oct 06, 2003 8:18 am
Location: Kettering, Ohio

Postby killian96ss » Tue Sep 13, 2005 11:12 am

My dealer is telling me that my air bag module which takes input from all the sensors is bad and needs to be replaced. They want $300 for the module and $300 for labor, and apparently extended warranties won't cover any problems within the air bag system. :shock: This is a major safety item, and I can't believe neither GM nor my extended warranty will cover this. :x Right now my air bag system is completely disabled because of this failure and won't work in an accident. :x Has anyone here ever replaced this module? Every time I have been off road on very bumpy trails the light would come on and then go off after a day or two. I think the module failed do to the vibrations. :roll:

Steve
2005 ZR2 Blazer / Mods- Spectre CAI, Descreened MAF, Shaved Throttle Blade, 31" Goodyear Kevlar MT/R's, Black Rock Rims, MSD Street Fire CDI & Super Conductor Wires, Accel Cap, Rotor & Coil, Flowmaster 30 Series, Gibson Tailpipe, ES Bushings, Goodridge Brake Lines, Power Slot Rotors - 1996 Impala SS / Mods- Too Many To List - 1988 S10 Blazer / Mods- Too Many To List - 2001 S10 Crew Cab 4x4 / Mods- Too Many To List *Wrecked 12/06*
User avatar
killian96ss
Crew K Elite
Crew K Elite
 
Posts: 2666
Joined: Tue Sep 09, 2003 11:53 am
Location: Rocklin, California

Postby SONOMA915 » Tue Sep 13, 2005 2:40 pm

Hey, just my .02. I have experienced alot of airbag problems, working here at a VW dealer. Even if the light goes out it still stores a code but it is only a sporadic code. There should still be a code even of the light goes out.
2004 GMC Sonoma ZR5 (Sold)
2005 Toyota Tacoma
User avatar
SONOMA915
Crew Elite
Crew Elite
 
Posts: 281
Joined: Thu Jun 16, 2005 8:56 am
Location: EL PASO TEXAS

Postby adrenalnjunky » Wed Sep 14, 2005 6:21 am

killian96ss wrote:My dealer is telling me that my air bag module which takes input from all the sensors is bad and needs to be replaced. They want $300 for the module and $300 for labor, and apparently extended warranties won't cover any problems within the air bag system. :shock: This is a major safety item, and I can't believe neither GM nor my extended warranty will cover this. :x Right now my air bag system is completely disabled because of this failure and won't work in an accident. :x Has anyone here ever replaced this module? Every time I have been off road on very bumpy trails the light would come on and then go off after a day or two. I think the module failed do to the vibrations. :roll:

Steve


Personal opinion - wear your seatbelts, and make all your passengers properly buckle up. Pray you aren't plowed into head-on by a rogue Wells Fargo truck at 80 mph, and be glad that your bags can't deploy in other situations.

I've now had 3 vehicles deploy airbags in my immediate family, and in all situations the damage/replacement of the SIR system and everything it breaks (dash, windshield, etc..) - the cost of fixing all of that is equal to or more than the actual body damage. It tacked $3600 onto the repair bill for my 97 Z24 - the total repair was $7800, which almost made the insurance company total a 9 month old car. Would have been about $4000 in just replacing sheetmetal otherwise.

Just my opinion.
Thanks, CHRIS
2000 S10 Blazer 4x4 4Dr. -- 2" PA BodyLift, Daystar Shackles, TB Crank, 1.75" Rear wheel spacers, Yakima roofrack, 30" BFG AT's.
1969 VW Bug -- airbagged and in pieces.
1962 VW Karmann ghia -- rusting over in the corner. "That's not a tool--that's a damn brick!"
User avatar
adrenalnjunky
Crew Elite
Crew Elite
 
Posts: 895
Joined: Sun Jul 27, 2003 11:32 am
Location: West Monroe, Louisiana

Postby killian96ss » Wed Sep 14, 2005 12:52 pm

I have never really liked the idea of something popping out in my face unexpectantly, but I have a friend who is alive because his air bag did deploy in a head on collision. He was driving a newer Mustang on a nearby 2 lane highway when an old lady in a Lincoln swerved into his lane and hit him head on. Both cars were traveling about 60 mph when this happened. The old lady died on impact, and my friend broke several bones, crushed 3 vertibrae, and required immediate brain surgery! He was told if there was no air bag he would surely be dead. :shock:

Steve
2005 ZR2 Blazer / Mods- Spectre CAI, Descreened MAF, Shaved Throttle Blade, 31" Goodyear Kevlar MT/R's, Black Rock Rims, MSD Street Fire CDI & Super Conductor Wires, Accel Cap, Rotor & Coil, Flowmaster 30 Series, Gibson Tailpipe, ES Bushings, Goodridge Brake Lines, Power Slot Rotors - 1996 Impala SS / Mods- Too Many To List - 1988 S10 Blazer / Mods- Too Many To List - 2001 S10 Crew Cab 4x4 / Mods- Too Many To List *Wrecked 12/06*
User avatar
killian96ss
Crew K Elite
Crew K Elite
 
Posts: 2666
Joined: Tue Sep 09, 2003 11:53 am
Location: Rocklin, California

Postby barch97 » Tue Oct 18, 2005 2:45 am

So, as far as I can tell from what's been posted here and here and here, I can either pay $600 to get my airbag light shut off or wait another 251 clear starts and it'll go off on its own?
"Some people are like Slinkies. Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs."
User avatar
barch97
Crew K Elite
Crew K Elite
 
Posts: 1136
Joined: Thu Nov 21, 2002 11:08 am
Location: New Jersey

Postby killian96ss » Tue Oct 18, 2005 7:13 am

barch97 wrote:So, as far as I can tell from what's been posted here and here and here, I can either pay $600 to get my airbag light shut off or wait another 251 clear starts and it'll go off on its own?
It depends on why it's on in the first place. If the control module has gone bad like mine, then it will never go off until the module is replaced. When the light is on (for any reason), the whole SRS system is completely disabled and won't work in an accident. When I first got my CC the light would occasionally come on after driving on really bumpy dirt roads, or driving through deep water, but then it would usually turn off after a day or two. I now realize that the control module was probably starting to fail way back then. :roll:

Steve
2005 ZR2 Blazer / Mods- Spectre CAI, Descreened MAF, Shaved Throttle Blade, 31" Goodyear Kevlar MT/R's, Black Rock Rims, MSD Street Fire CDI & Super Conductor Wires, Accel Cap, Rotor & Coil, Flowmaster 30 Series, Gibson Tailpipe, ES Bushings, Goodridge Brake Lines, Power Slot Rotors - 1996 Impala SS / Mods- Too Many To List - 1988 S10 Blazer / Mods- Too Many To List - 2001 S10 Crew Cab 4x4 / Mods- Too Many To List *Wrecked 12/06*
User avatar
killian96ss
Crew K Elite
Crew K Elite
 
Posts: 2666
Joined: Tue Sep 09, 2003 11:53 am
Location: Rocklin, California

Postby barch97 » Tue Oct 18, 2005 7:29 am

hmm...

Well, it came on for the first time yesterday while bouncing relatively violently over a railroad crossing. It stayed on for the rest of my ride to work (about five more minutes). When I started up to go home it didn't come until I was a block or so down the road. Then it stayed on for about twenty minutes and went off for about the same amount of time only to come back on just before I got home.

So, I disconnected the battery for about ten minutes in the hope that this would reset whatever was triggered. But, later last night I ran out for a bit and it came on again about a block from home and stayed on for the duration of a short trip. Similar activity of on/off cycling on the way to work this morning.

Maybe my module is going also?

Or, maybe I shook something loose crossing the train tracks yesterday?
"Some people are like Slinkies. Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs."
User avatar
barch97
Crew K Elite
Crew K Elite
 
Posts: 1136
Joined: Thu Nov 21, 2002 11:08 am
Location: New Jersey

Postby killian96ss » Tue Oct 18, 2005 7:58 am

Barch97, it sounds like your light is behaving like mine used to before it finally just gave up and decided to stay on. When mine first started doing this it seemed as though my CC could sense the dealership, because every time I took it in for this problem the light would magically go off before I could get there. :roll: If I could have proved that something was wrong before the factory warranty expired, then they would have fixed it, but now that the light is stuck on and the control module has been found to be defective, GM and my extended warranty company refuse to replace the module since I currently have 64k miles. I only had 22k miles when this problem first started, and it finally broke around 48k miles. :x I refuse to give up though, and I'm still going to try and get GM to cover this, especially since I have a documented complaint about this problem on an earlier service repair when I only had 24k miles.

Steve
2005 ZR2 Blazer / Mods- Spectre CAI, Descreened MAF, Shaved Throttle Blade, 31" Goodyear Kevlar MT/R's, Black Rock Rims, MSD Street Fire CDI & Super Conductor Wires, Accel Cap, Rotor & Coil, Flowmaster 30 Series, Gibson Tailpipe, ES Bushings, Goodridge Brake Lines, Power Slot Rotors - 1996 Impala SS / Mods- Too Many To List - 1988 S10 Blazer / Mods- Too Many To List - 2001 S10 Crew Cab 4x4 / Mods- Too Many To List *Wrecked 12/06*
User avatar
killian96ss
Crew K Elite
Crew K Elite
 
Posts: 2666
Joined: Tue Sep 09, 2003 11:53 am
Location: Rocklin, California

Postby barch97 » Tue Oct 18, 2005 8:01 am

So, if I just pull the fuse, the light will go off, therefore fixing the problem? :wink:


my warranty ran out about two years ago :roll:
"Some people are like Slinkies. Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs."
User avatar
barch97
Crew K Elite
Crew K Elite
 
Posts: 1136
Joined: Thu Nov 21, 2002 11:08 am
Location: New Jersey

Postby killian96ss » Tue Oct 18, 2005 8:12 am

barch97 wrote:So, if I just pull the fuse, the light will go off, therefore fixing the problem? :wink:


my warranty ran out about two years ago :roll:
:lol: Well at least you wouldn't have to look at that stupid light anymore. :lol:

Steve
2005 ZR2 Blazer / Mods- Spectre CAI, Descreened MAF, Shaved Throttle Blade, 31" Goodyear Kevlar MT/R's, Black Rock Rims, MSD Street Fire CDI & Super Conductor Wires, Accel Cap, Rotor & Coil, Flowmaster 30 Series, Gibson Tailpipe, ES Bushings, Goodridge Brake Lines, Power Slot Rotors - 1996 Impala SS / Mods- Too Many To List - 1988 S10 Blazer / Mods- Too Many To List - 2001 S10 Crew Cab 4x4 / Mods- Too Many To List *Wrecked 12/06*
User avatar
killian96ss
Crew K Elite
Crew K Elite
 
Posts: 2666
Joined: Tue Sep 09, 2003 11:53 am
Location: Rocklin, California

Postby green02crew » Sun Aug 10, 2008 5:15 pm

Apparently my airbag light comes on after exposure to water. It has happened twice now fording deep water or torrential downpours leaving small bodies of water along the road and blasting through them. Is there any fear of airbag deployment? The light turns off after some time drying out.
2002 S-10 Crew Cab
Too Many Mods Check the Readers Rides Page
User avatar
green02crew
Crew Elite
Crew Elite
 
Posts: 863
Joined: Mon Nov 12, 2007 7:56 pm
Location: Northern NH

Postby HenryJ » Sun Aug 10, 2008 5:24 pm

The light on signals that the system is disabled. Once the system is again active the light goes off.

"Speed doesn't kill, suddenly becoming stationary does." - Richard Hammond
"Speed is just a matter of Money - How fast do YOU want to go?"-Mechanic from Mad Max-
If at first you don't succeed - Don't take up Skydiving!
- ThunderII KE7CSK
User avatar
HenryJ
Admin K Elite
Admin K Elite
 
Posts: 12693
Joined: Tue Oct 01, 2002 9:14 pm
Location: Ontario, Oregon

Re: Air Bag Light On ?

Postby blaz » Thu Apr 07, 2011 7:30 pm

Back from the dead thread. :roflmao:

My air bag light came on. The code said that the drivers air bag loop is open, thus leading me to the clock spring. Anyone have a step by step for replacing it? I will test the conductors before replacing it, but as I turn the wheel the light will go on and off so I think there is an almost broken wire :rant: . Any links with pics would be awesome!

TIA
Paul.
blaz
Crew Elite
Crew Elite
 
Posts: 177
Joined: Tue Dec 16, 2008 7:30 pm
Location: Winnipeg, Manitoba, Canada

Re: Air Bag Light On ?

Postby blaz » Fri Apr 08, 2011 4:10 pm

Did the clock spring today and no more airbag light! :wink: The job is not too bad at all. It took me about 2 hours start to finish thanks to a couple of youtube vids and a write up on other s10 sites.

Lots of preperation makes the job so much easier! :rock:
blaz
Crew Elite
Crew Elite
 
Posts: 177
Joined: Tue Dec 16, 2008 7:30 pm
Location: Winnipeg, Manitoba, Canada

Re: Air Bag Light On ?

Postby F9K9 » Sat Apr 09, 2011 3:06 am

Clock springs can be intimidating but, knowledge is power. :thumb:
"For those who have fought for it, FREEDOM has a taste that the protected will never know."
GUIDE TO SEARCHING. (Some of the forum software is different but, it has helped me a lot.)

"Those who don't know history are destined to repeat it." Edmund Burke
User avatar
F9K9
Mod K Elite
Mod K Elite
 
Posts: 6179
Joined: Sun May 30, 2004 12:26 pm
Location: London, Kentucky, United States

Re: Air Bag Light On ?

Postby blaz » Sat Apr 09, 2011 6:24 pm

The air bag was my main concern because I have never had to deal with them before. Caution is required but common sense is a valuable tool also. :lol:
blaz
Crew Elite
Crew Elite
 
Posts: 177
Joined: Tue Dec 16, 2008 7:30 pm
Location: Winnipeg, Manitoba, Canada


Return to Stock Electrical / Audio / Lighting



Who is online

Users browsing this forum: Bing [Bot] and 1 guest