flood damage

The stock systems

Moderator: F9K9

flood damage

Postby Hartleybl » Tue May 06, 2014 8:43 pm

Ok we got 25 inches of rain about a week ago and my truck was deemed a total loss water was up slightly above the seats im buying it back for scrap price 760$$ my question is... What other modules besides the tccm and bcm are below the glove box and ash tray I am qualified to repair the vehicle and get a rebuilt title It never hurts to get all the info possible before tackling something like this and I ask you guys because I know of the wealth of crew cab info people like ya'll have thanks in advance
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby AVTekk » Thu May 08, 2014 11:12 am

The airbag module is under center console, thats the only other one i can think of.
User avatar
AVTekk
Crew Elite
Crew Elite
 
Posts: 106
Joined: Mon Nov 22, 2004 2:09 pm
Location: South Plainfield, NJ

Re: flood damage

Postby HenryJ » Thu May 08, 2014 3:56 pm

I have a BCM leftover. It would need to be VIN matched though. That might be a deal breaker.

"Speed doesn't kill, suddenly becoming stationary does." - Richard Hammond
"Speed is just a matter of Money - How fast do YOU want to go?"-Mechanic from Mad Max-
If at first you don't succeed - Don't take up Skydiving!
- ThunderII KE7CSK
User avatar
HenryJ
Admin K Elite
Admin K Elite
 
Posts: 12691
Joined: Tue Oct 01, 2002 9:14 pm
Location: Ontario, Oregon

Re: flood damage

Postby Hartleybl » Thu May 08, 2014 10:17 pm

Yeah I'm not sure how to go about vin matching...thanks anyways ...is it the bcm that controls the security system and keyless entry? And the tccm would control the 4x4 buttons? They don't even light up courtesy lights don't work everything else seems ok... HVAC works.. Power windows and locks work... Drivers door wont unlock but will lock radio works... Overhead console works....gauge cluster works... Needs a new engine... Bent rod/rods trans is full of water ... I'm sure the diffs are 2... U pull it is full of new blazer 4x4s... So parts aren't a problem... Entire differentials front or rear 79$ switches like the blazer hatch and wiper panel switch is 3.99 every switch I bought was 3.99... I bought the truck back for 757.61... State farm paid 10700 for the truck.. I came out good I think I have my truck and don't owe 10k to a finance company anymore and they are working with me on the deductible that gap insurance wouldn't cover so she is canceling the gap policy and using the prorated refund towards the deductible so I am happy about it... I just have to fix it have a state inspection and get a rebuilt title
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby Hartleybl » Thu May 08, 2014 10:20 pm

Also the airbags seem ok the light flashes 5-6 times like it says in the owners manual and goes out security light stays on and that's it...and on that bcm... How would I vin match it? That sounds like a dealership function???does it by chance have tow haul feature ? And also I can't find any info about Alabama laws and engine swaps alot of people do it and we don't have an annual inspection like some states but being as mine will have to be inspected.... I want to go ahead and drop a 350 in it but I don't want that to make it fail the inspection.... My best guess is as long as its fuel injected and has catalytic converter's it should be ok... But I'd like to know before hand....
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby HenryJ » Fri May 09, 2014 4:54 am

VIN matching would be done by a dealership. I have no experience with that. Without it the MIL will be illuminated. The one I have is the stock one. No tow-haul.

"Speed doesn't kill, suddenly becoming stationary does." - Richard Hammond
"Speed is just a matter of Money - How fast do YOU want to go?"-Mechanic from Mad Max-
If at first you don't succeed - Don't take up Skydiving!
- ThunderII KE7CSK
User avatar
HenryJ
Admin K Elite
Admin K Elite
 
Posts: 12691
Joined: Tue Oct 01, 2002 9:14 pm
Location: Ontario, Oregon

Re: flood damage

Postby Hartleybl » Sat May 10, 2014 6:13 pm

Removed the steering shaft and pulled the sparkplugs out shot water out and spun over just fine... Prolly gonna do head gaskets and intake gasket but I got new plugs and wires and gonna see if she starts tomorrow it built 40+psi ofoil pressure
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby Hartleybl » Sat May 10, 2014 11:16 pm

Well I put the plugs and wires on it just spins over... Guess it needs that bcm to start ? Fuel pump works fine..as do all the gauges and overhead console and radio no interior lights...and the security light stays on... So I'm guessing that has it in lock down mode and won't give it any spark....
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby Hartleybl » Tue May 13, 2014 6:08 pm

got the engine to start... but the security system wont let it run.. pulled the BCM and RKE and TCCM modules... seperated the housings.... sprayed the boards down with wd40 and am waiting for them to dry and then i will re-try them.... the bcm and tccm just had a slight film of corrosion on them wd40 took that off.. the rke has a little black spot on it so i'm sure its shot... sprayed all the connectors with wd40 .. just wishful thinking im sure they will all need to be replaced but.... its worth a try...
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby AVTekk » Wed May 14, 2014 10:34 am

You said the rods were bent so why are you trying to start it? I dont know about Al but here in NJ I highly doubt they will pass it with a different engine.
User avatar
AVTekk
Crew Elite
Crew Elite
 
Posts: 106
Joined: Mon Nov 22, 2004 2:09 pm
Location: South Plainfield, NJ

Re: flood damage

Postby Hartleybl » Wed May 14, 2014 9:13 pm

I pulled the steering shaft out and removed the center plug on drivers side so all 6 have been pulled cylinders purged and sparkplugs and wires replaced number 3 also shot water out when I removed it I can now get it to run but the security system won't let it keep running.. It doesn't knock it doesn't smoke it doesn't even rattle but the only way I can keep it running is by taking a pump up sprayer full of gas and feeding the throttle body I pulled the bcm...rke and tccm modules and they are shot rke had a single burnt spot on the board... The bcm and tcm had a layer of rust and corrosion built up across the entire board.... I'm waiting till Friday and I'm going to the u pull it for a bcm rke and tccm I've already paid for the truck 757.61 scrap value... Insurance company has to send the title to have it branded as a flood title then when I get the title I fill out a form mail it to Montgomery Alabama DMV to request a state inspection they will tell me where to take it and for 95 dollars I will get a rebuilt title and go register for a new tag
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby ApproachMedium » Thu May 15, 2014 11:36 am

What really has to be done with VIN matching? The VIN on my PCM does not match my truck since the V8 swap. Its a random vin from some van they used. Once it came back after doing the whole 30 mins of key cycling and relearning the security system should allow it to run and trade all the info. It can be done in a few mins with a Tech 2 like the one I have, but you have to find a shop or dealer with one and probably pay them to do it.
Knowledge has no value unless its shared with others.
Exploration Machine- 02' CC V8 swap. 300K+
Portable Roller Coaster- 07' MKV VW GTI
Its another Jeep- 98 TJ
ApproachMedium
Crew Elite
Crew Elite
 
Posts: 966
Joined: Tue Nov 17, 2009 1:20 am
Location: Jersey Shore

Re: flood damage

Postby Hartleybl » Thu May 15, 2014 10:39 pm

Tomorrow I'm going to Theodore Alabama to barrys u pull it and getting a bcm tccm and rke module in gonna look for one that has tow/haul and the fancy overhead console also...there is a 99 bravada that has these features but I'm not sure if a 99 bcm will mesh up with a 2004 they have several nice blazers with leather seats and other goodies most are 4x4 so I'll most likely be getting the modules from one of the blazers but I'll let ya know if I have to have a dealer or shop do anything to it but if it worked for you doing a v8 swap surely it will work for me doing the 30 min relearn
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby HenryJ » Fri May 16, 2014 4:47 am

I ran with the tow / haul mode and a BCM that was not VIN matched. Beware that once you do it it will set the MIL and there is no going back after a while. Even the stock BCM will no longer satisfy the error condition. That is where you must have a TechII to correct the VIN mismatch.

"Speed doesn't kill, suddenly becoming stationary does." - Richard Hammond
"Speed is just a matter of Money - How fast do YOU want to go?"-Mechanic from Mad Max-
If at first you don't succeed - Don't take up Skydiving!
- ThunderII KE7CSK
User avatar
HenryJ
Admin K Elite
Admin K Elite
 
Posts: 12691
Joined: Tue Oct 01, 2002 9:14 pm
Location: Ontario, Oregon

Re: flood damage

Postby Hartleybl » Fri May 16, 2014 6:56 pm

Thanks for the info I'm gonna have to have the new bcm vin matched anyways I got all functions back tried the relearn process but it still won't start the security light stays on constantly again but keyless entry works all the interior lights work the 4wd lights all flash on but go right back out...might have got a bad tccm not sure but the bcm came from a 2000 model blazer Lt 2wd so I'm waiting till next week to have it towed to southern Chevrolet and it will cost 108.00 for vin matching also got lucky while over at the u-pull-it in theodore found a newly arrived 98 blazer 4x4 lt and got the leather seats almost mint condition front and back for 73$ maybe i should have gotten the bcm out of it since it was a 4x4... but im worried that the 2000 model bcm might be to old... all the ones i find listed for compatability are 2002 and up.. the guy at the salvage yard said he thought 98-2001 would interchange but wasnt sure if it would work on mine.. he said i can bring it back... i talked to the dealership and the advisor was 100% sure it would need a vin match reguardless since it wasnt the factory bcm...
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby ApproachMedium » Fri May 16, 2014 7:36 pm

Anything for your truck needs to come from a 2000 up, computer wise. Anything in a 98 or 99 truck is not going to like talking to the Class 2 serial data bus. That includes overhead console DIC, gauge clusters, bcms etc.
Knowledge has no value unless its shared with others.
Exploration Machine- 02' CC V8 swap. 300K+
Portable Roller Coaster- 07' MKV VW GTI
Its another Jeep- 98 TJ
ApproachMedium
Crew Elite
Crew Elite
 
Posts: 966
Joined: Tue Nov 17, 2009 1:20 am
Location: Jersey Shore

Re: flood damage

Postby Hartleybl » Fri May 16, 2014 9:50 pm

Could the rds thing behind the radio be causing the security problems? Cause minus the 4wd the 2000 model blazer Lt I got this bcm from was fully loaded....all interior features work... Now.. But the airbag light stays on with this bcm... I'm going back over tomorrow to the u pull it and see if I can find a newe 4x4... All the 4x4s were 99 or older that I found but I might find a newer 1 tomorrow... I'm still wondering why my 4x4 wont work... New dash switch and tccm but all 3 lights flash on when I turn the key and they go out and I can't take it out of 4low.... I found a module under the center console which I was told is the"black box" for airbag data.... It was completely submerged overnight also so I'm sure it needs replaced ... Maybe why my air bag light stays on now also...
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby HenryJ » Sat May 17, 2014 5:15 am

Grab a transfercase (encoder) motor too.

"Speed doesn't kill, suddenly becoming stationary does." - Richard Hammond
"Speed is just a matter of Money - How fast do YOU want to go?"-Mechanic from Mad Max-
If at first you don't succeed - Don't take up Skydiving!
- ThunderII KE7CSK
User avatar
HenryJ
Admin K Elite
Admin K Elite
 
Posts: 12691
Joined: Tue Oct 01, 2002 9:14 pm
Location: Ontario, Oregon

Re: flood damage

Postby Hartleybl » Sat May 17, 2014 9:55 pm

Newest truck I could find was an 01 Sonoma with the 2.2 base model so I guess I'm gonna get the pcm for less vin matched bcm from eBay for 200 they say that they can vin match it before its put in the truck... And will provide proof it was indeed done... And I can request additional features be turned on so I guess I'm gonna go that route no luck on an encoder motor... Maybe next time I can find one. I did find a 96 blazer with manual transfer case.. Very tempting... I'll have to read more on the swap tho... Thanks for the continued help and support
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby Hartleybl » Tue Jun 03, 2014 1:54 pm

well i flushed the trans... it works alot better but it still shifts out at about 3k-3500 rpm under WOT...and if your going at hwy speeds and floor it to pass someone it wont downshift automatically... you can manually shift it at any rpm 4x4 works again... put a need tccm and some tinkering... remarkably the front diff was clean and water free first gear holds till about 2500 rpm before it shifts itself out exept WOT... it will go 3500.... any suggestions... ?
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby Hartleybl » Sun Jun 08, 2014 11:14 pm

Well Henry you were definitely right about the encoder motor I push the buttons and they just flash.. If I push 4hi or low both hi and low lights stay lit up you can here the motor engage but it wont make a full cycle to 4hi... I can force it into 4 lo and it will do a full cycle for the encoder motor... But when in 4 lo it only has 1st and 2nd.. It wont shift to 3rd and it just revs and wo t pull.... Does fine in 2wd tho.. In all gears also took it buy AutoZone for a code scan to see if they could tell me why my airbag light was on he said no codes unplugged his scanner and started walking off like I wasn't talking to him..
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL

Re: flood damage

Postby HenryJ » Mon Jun 09, 2014 4:51 am

If it won't read codes, check the courtesy lamp fuse. That powers the port :)

"Speed doesn't kill, suddenly becoming stationary does." - Richard Hammond
"Speed is just a matter of Money - How fast do YOU want to go?"-Mechanic from Mad Max-
If at first you don't succeed - Don't take up Skydiving!
- ThunderII KE7CSK
User avatar
HenryJ
Admin K Elite
Admin K Elite
 
Posts: 12691
Joined: Tue Oct 01, 2002 9:14 pm
Location: Ontario, Oregon

Re: flood damage

Postby Hartleybl » Sun Jun 22, 2014 5:49 pm

Thanks that was it... Now after everything else is good I'm getting a misfire on cyl1 random misfire and injector circuit open and evap valve malfunction.... I got all but the injector circuit...any suggestions on it?... P0200
Hartleybl
Crew Elite
Crew Elite
 
Posts: 116
Joined: Sun Nov 10, 2013 5:29 pm
Location: Foley, AL


Return to Stock Electrical / Audio / Lighting



Who is online

Users browsing this forum: No registered users and 1 guest