Warming up

This is the place for all those mods

Moderator: F9K9

Warming up

Postby green02crew » Wed May 28, 2008 7:20 pm

When I first start driving for the day and my truck heats up it gets to operating temps then goes about 15 degrees above the thermostat temp then drops right down to normal running at ~177. This seemed to start after I changed to the larger radiator.

It isn't really a problem I'm just curious as to why/how it would do that. It never did this before the new radiator, that I had noticed at least. It cools off in about 3 seconds, just gets hot then drops right down to normal temps.

Any ideas?
2002 S-10 Crew Cab
Too Many Mods Check the Readers Rides Page
User avatar
green02crew
Crew Elite
Crew Elite
 
Posts: 863
Joined: Mon Nov 12, 2007 7:56 pm
Location: Northern NH

Postby HenryJ » Wed May 28, 2008 7:23 pm

Larger reservoir of unheated coolant. The temp takes a drop when the thermostat opens the first time.

"Speed doesn't kill, suddenly becoming stationary does." - Richard Hammond
"Speed is just a matter of Money - How fast do YOU want to go?"-Mechanic from Mad Max-
If at first you don't succeed - Don't take up Skydiving!
- ThunderII KE7CSK
User avatar
HenryJ
Admin K Elite
Admin K Elite
 
Posts: 12697
Joined: Tue Oct 01, 2002 9:14 pm
Location: Ontario, Oregon

Postby green02crew » Thu May 29, 2008 7:53 pm

Ahhh gotcha. That makes sense. Thanks!
2002 S-10 Crew Cab
Too Many Mods Check the Readers Rides Page
User avatar
green02crew
Crew Elite
Crew Elite
 
Posts: 863
Joined: Mon Nov 12, 2007 7:56 pm
Location: Northern NH


Return to Crew Cab Modifications



Who is online

Users browsing this forum: No registered users and 1 guest