New and needing help

Forum rules, questions, How-to's for posting pictures and making links, etc..

Moderator: HenryJ

New and needing help

Postby GooseGun » Wed Nov 16, 2016 5:29 pm

I have been a long time reader of this forum, but just now registered. I plan to give any knowledge i have about these vehicles but honestly my ability's are limited to an average home mechanic. My first small Chevy truck was and is a 1976 LUV. I'm currently working on it. But the vehicle i need help with is my s-10. I am an industrial mechanic so i am mechanically inclined but like most, my short comings are the electrical side of things, which i am currently working on, I am going to school. So a year ago i bought what i though would be a consolation truck. I worked at a Diesel performance shop Edge products. So naturally i wanted a Duramax. But I found out i was lucky and getting a baby boy instead haha. So i found this 02 s10 crew cab with 70K miles. I figured itd get good gas mileage and still let me go hunting. Then i got a slap in the face and i have been fighting it ever since. So when i got it i rebuilt the front end. Then i tuned it up with all filters replaced, plugs& wires, PCV valve, cap and rotor. Then i started getting a misfire. I had a P0101 code for MAF sensor. Replaced it and made no difference. Turns out my distributor had a bad bushing. Replaced it and thought itd start running better but that all had ruined my CAT. So i replaced the cat, all o2 sensors, ignition coil, and Map sensor. Started driving it again and i got a hole in my heater core, replaced it and now am fighting 6 more codes that i cant get to go away. The truck seems to run great but i cant get rid of the codes. And with two being that its running rich i don't want to drive it much. I need to get it fixed, being hunting season and all. It wont pass safety with the check engine light on. The codes are P0101, p0135, p0155, p0172, p0175, u1301. so if anyone has any ideas on what it could be i would love to hear. I did all the work myself but i did make a mistake of not buying all Acdelco parts. I did buy all OE parts except the CAT, MAF, and o2 sensors. I have a relative with a shop in WY, im in UT so he said i could use his identifix account and contact them. They guarantee what i replace. I just wanted to get a few opinions. Thanks ahead to whoever responds.
GooseGun
New Member
New Member
 
Posts: 2
Joined: Wed Nov 16, 2016 5:07 pm

Re: New and needing help

Postby GooseGun » Wed Nov 16, 2016 5:33 pm

i forgot to add, i had a p0300 code with the p0101 so random misfire, thats what ruined my cat. But it is gone now.
GooseGun
New Member
New Member
 
Posts: 2
Joined: Wed Nov 16, 2016 5:07 pm


Return to Forum Information



Who is online

Users browsing this forum: No registered users and 1 guest