brake issues

Anything related to the factory RPO Crew Cab.

Moderator: F9K9

brake issues

Postby RebelKid1822 » Mon Oct 20, 2014 8:20 am

Okay guys im stumped on this one. On my crew when I am in reverse, I have alot more brake pedal travel. Forward is normal. Discs all around. All new calipers, pads, rotors, and brake lines. Its been like this for a while. Any ideas?
User avatar
RebelKid1822
Crew Elite
Crew Elite
 
Posts: 145
Joined: Tue Sep 13, 2011 3:40 pm
Location: Brimfield, OH

Re: brake issues

Postby Horsehammerr » Tue Oct 21, 2014 4:33 am

Back up slower
'02ZR5 YellowCruzCab-Airbox chopped,Quadlights,Intake defuser chopped,Precat chopped,HD Bilsteins, 8x15x3 3/4"back space alloys,30x9.50R15 Hankook Dynapro ATM RF10's, Gutted Main Cat, ZQ8 rear Sway Bar, Full size Bump Stops: solid front, hollow rear, Front & Rear wheel wells and ZR5 flares SKIDZ cut, 1.5" Daystar Lift Shackles, TB's cranked 1.5"
User avatar
Horsehammerr
Crew Elite
Crew Elite
 
Posts: 715
Joined: Sun Apr 15, 2007 2:03 pm
Location: Kimberling City, MO.

Re: brake issues

Postby RebelKid1822 » Tue Oct 21, 2014 4:47 am

Lol I am going slow. Usually I notice it when backing into a parking spot.
User avatar
RebelKid1822
Crew Elite
Crew Elite
 
Posts: 145
Joined: Tue Sep 13, 2011 3:40 pm
Location: Brimfield, OH

Re: brake issues

Postby Horsehammerr » Wed Oct 22, 2014 4:22 am

I had a similar problem when I put all new pads and calipers on. It took a lot of extra bleeding on the front to get it right.Has been great for 3yrs. now, forward and reverse.
'02ZR5 YellowCruzCab-Airbox chopped,Quadlights,Intake defuser chopped,Precat chopped,HD Bilsteins, 8x15x3 3/4"back space alloys,30x9.50R15 Hankook Dynapro ATM RF10's, Gutted Main Cat, ZQ8 rear Sway Bar, Full size Bump Stops: solid front, hollow rear, Front & Rear wheel wells and ZR5 flares SKIDZ cut, 1.5" Daystar Lift Shackles, TB's cranked 1.5"
User avatar
Horsehammerr
Crew Elite
Crew Elite
 
Posts: 715
Joined: Sun Apr 15, 2007 2:03 pm
Location: Kimberling City, MO.

Re: brake issues

Postby RebelKid1822 » Wed Oct 22, 2014 4:32 am

Ok thanks. Ill try bleeding it again.
User avatar
RebelKid1822
Crew Elite
Crew Elite
 
Posts: 145
Joined: Tue Sep 13, 2011 3:40 pm
Location: Brimfield, OH

Re: brake issues

Postby RebelKid1822 » Wed Oct 29, 2014 4:04 am

Bled the brakes again, 100 times better.
User avatar
RebelKid1822
Crew Elite
Crew Elite
 
Posts: 145
Joined: Tue Sep 13, 2011 3:40 pm
Location: Brimfield, OH


Return to Stock Crew Cab



Who is online

Users browsing this forum: Bing [Bot] and 1 guest